Fandom

OpenBSD Wiki

Trunk failover issue

Forum page

34pages on
this wiki
Add New Page

Hi All

I'm having problems configuring a trunk port in failover mode for openBSD 4.9.
The situation is this, I have one bsd with two interfaces(vic0 and vic1) that are directly connected to a simple switch on the third port of the switch I have a windows machine.

The idea is that I want the BSD to have redundant interfaces and I want to do it by uniting the two vic cards in to one failover trunk interface.
It looks simple but no matter what I try it is not working:

This is my configuration:
# ifconfig

vic0: flags=8b43<UP,BROADCAST,RUNNING,PROMISC,ALLMULTI,SIMPLEX,MULTICAST> mtu 1500
lladdr 00:0c:29:87:da:42
priority: 0
trunk: trunkdev trunk10
media: Ethernet autoselect
status: active
inet6 fe80::20c:29ff:fe87:da4c%vic0 prefixlen 64 scopeid 0x1

vic1: flags=8b43<UP,BROADCAST,RUNNING,PROMISC,ALLMULTI,SIMPLEX,MULTICAST> mtu 1500
lladdr 00:0c:29:87:da:42
priority: 0
trunk: trunkdev trunk10
media: Ethernet autoselect
status: active
inet6 fe80::20c:29ff:fe87:da56%vic1 prefixlen 64 scopeid 0x2

trunk10: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> mtu 1500
lladdr 00:0c:29:87:da:42
priority: 0
trunk: trunkproto failover
trunkport vic1
trunkport vic0 master,active
groups: trunk
media: Ethernet autoselect
status: active
inet6 fe80::20c:29ff:fe87:da42%trunk10 prefixlen 64 scopeid 0x9
inet 10.30.0.5 netmask 0xffffff00 broadcast 10.30.0.255
#
The windows machine has IP: 10.30.0.100/24 and at the moment the ping is going fine but if I put vic0 down the ping stops ;(
Please advice on how can this be fixed or if Im missconfiguring something!

Best Regards
Forums: Index > OpenBSD > Trunk failover issue

Ad blocker interference detected!


Wikia is a free-to-use site that makes money from advertising. We have a modified experience for viewers using ad blockers

Wikia is not accessible if you’ve made further modifications. Remove the custom ad blocker rule(s) and the page will load as expected.