FANDOM


Install Edit

Install the set comp<ver>.tgz when you are installing OpenBSD.

Using Edit

For...
the C compiler: gcc
the C++ compiler: g++
the Fortran compiler: gfortran
the linker: ld
the assembler: as
the C preprocessor: cpp
GNU target: <arch>-unknown-openbsd<version> (ex. powerpc-unknown-openbsd3.4)

Versions Edit

GCC: 2.95.3 and 3.3.5 both patched with SSP
Binutils: 2.15

PCC noteEdit

Recently PCC has been added to the package tree. It is a C compiler and can be accessed using pcc.